Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Senior Member Drache's Avatar
    Join Date
    Apr 2012
    Location
    Williams Lake, BC
    Posts
    7,754

    Need help with mossberg

    Can anyone with a mossberg 590 please post a close up picture of their tube where it goes into the receiver. I'm just wondering if mine is supposed to have a gap.

  2. #2
    Senior Member Foxer's Avatar
    Join Date
    Jan 2014
    Location
    Vancouver
    Posts
    17,799
    you mean the barrel or the mag tube?

  3. #3
    Senior Member Drache's Avatar
    Join Date
    Apr 2012
    Location
    Williams Lake, BC
    Posts
    7,754
    mag tube. Mine seems to have a gap that appears it's not fully screwed in

  4. #4
    Untouchable FlyingHigh's Avatar
    Join Date
    Mar 2012
    Location
    Grande Prairie, AB
    Posts
    4,444
    I have a 590A1 i can take a picture if wheb i get home from work if that will help. I think that part of the gun should be the same as a 590.
    I'd rather make a difference than a dollar.

  5. #5
    Senior Member Drache's Avatar
    Join Date
    Apr 2012
    Location
    Williams Lake, BC
    Posts
    7,754
    Quote Originally Posted by FlyingHigh View Post
    I have a 590A1 i can take a picture if wheb i get home from work if that will help. I think that part of the gun should be the same as a 590.
    Yup. The only difference is the barrel on yours is thicker and the trigger guard is metal.

  6. #6
    Untouchable FlyingHigh's Avatar
    Join Date
    Mar 2012
    Location
    Grande Prairie, AB
    Posts
    4,444
    I'm assuming it's the extra threads you're referring to. Here's my 590A1. My mag tube is screwed right tight and I have an extra thread or two showing. I just checked my Mossberg Maverick 88 and it's the same, tightened all the way and a couple threads showing. My guess is they do that to prevent some numpty over tightening and stripping the threads.

    I'd rather make a difference than a dollar.

  7. #7
    Senior Member Drache's Avatar
    Join Date
    Apr 2012
    Location
    Williams Lake, BC
    Posts
    7,754
    Thanks for the help!

    Having a problem with my follower/spring or something binding it up and every now and then making it hard to load a round into the tube.

  8. #8
    Senior Member Foxer's Avatar
    Join Date
    Jan 2014
    Location
    Vancouver
    Posts
    17,799
    Did you remove the 'stick' that limits the rounds to two? I don't know if that model does, but most of the ones i bought came with the mag limiter (for duck hunting) and it would sometimes fail to pass thru the hole it's supposed to be stuck in and make loading shells impossible. It's a straight tube - it shouldn't be able to 'bind' unless there's an obstruction i should think? (didn't leave a wrench or something in there when you had it apart didja?)

  9. #9
    Senior Member Deuce-deuce's Avatar
    Join Date
    Apr 2014
    Location
    Behind a large rock.
    Posts
    1,379
    I'm not a mossberg guy so take this with a grain of salt.
    I doubt it's the spring or follower. Could it be the shell latches?

  10. #10
    Senior Member Drache's Avatar
    Join Date
    Apr 2012
    Location
    Williams Lake, BC
    Posts
    7,754
    Quote Originally Posted by Foxer View Post
    Did you remove the 'stick' that limits the rounds to two? I don't know if that model does, but most of the ones i bought came with the mag limiter (for duck hunting) and it would sometimes fail to pass thru the hole it's supposed to be stuck in and make loading shells impossible. It's a straight tube - it shouldn't be able to 'bind' unless there's an obstruction i should think? (didn't leave a wrench or something in there when you had it apart didja?)
    This is a special purpose 590, 8+1 round capacity.

    Quote Originally Posted by Deuce-deuce View Post
    I'm not a mossberg guy so take this with a grain of salt.
    I doubt it's the spring or follower. Could it be the shell latches?
    Happens some of the times. Shell will go into the tube half way then it's like hitting a wall. Have to let the shotgun shell out a little then push it back in (sometimes it stops again other times it doesn't.

    Seems to only happen if I try to load shells gently. If I really load them in fast and hard it works fine.

Page 1 of 2 12 LastLast

Similar Threads

  1. New to me Mossberg 535
    By _JET_ in forum Shotguns
    Replies: 3
    Last Post: 12-29-2016, 09:52 AM
  2. MOSSBERG 183 kd ?
    By carjoc in forum Shotguns
    Replies: 1
    Last Post: 03-31-2016, 09:26 PM
  3. Mossberg 817
    By kennymo in forum Rimfire
    Replies: 0
    Last Post: 05-06-2015, 11:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •